run:
docker run -d
-e TZ=Asia/Shanghai
-v /etc/localtime:/etc/localtime:ro
-v /etc/timezone:/etc/timezone:ro
-v /dm:/opt/dmdbms/data
--name dm8
-p 5236:5236
4kerccc/dm8
如果需要设置mysql兼容模式,需要修改:/dm/dm.ini
COMPATIBLE_MODE = 4 #Server compatible mode, 0:none, 1:SQL92, 2:Oracle, 3:MS SQL Server, 4:MySQL, 5:DM6, 6:Teradata, 7:PG
修改完成后,再挂载进去,否则启动会报错: -v /dm/dm.ini:/opt/dmdbms/conf/dm.ini:ro
默认信息: SYSDBA_PWD=SYSDBA_abc123 SYSAUDITOR_PWD=SYSDBA_abc123 PAGE_SIZE=32 CASE_SENSITIVE=0 UNICODE_FLAG=1 LENGTH_IN_CHAR=1 BUFFER=3072 MODE=dmsingle INSTANCE_NAME=DMSERVER CHG_PASSWD=dmdba DM_USER_PWD=dmdba EXTENT_SIZE=32 BLANK_PAD_MODE=1 LOG_SIZE=512
Content type
Image
Digest
sha256:0f690b4b2…
Size
1.2 GB
Last updated
10 months ago
docker pull 4kerccc/dm8